{"action":"Upgrade scikit-learn to 0.24.dev0 or later.","affected":[{"fixed":"0.24.dev0","introduced":"0"}],"component":"scikit-learn","cve_ids":["CVE-2020-28975"],"ecosystem":"PyPI","epss":0.035,"exploited":false,"fixed_versions":["0.24.dev0"],"ghsa_id":"GHSA-jxfp-4rvq-9h9m","id":"tcs_01M5KG9B08H8TX07FJA2TZQHD6","modified_at":"2026-06-10T17:02:41.379397513Z","published_at":"2020-11-21T21:15:00Z","references":["https://osv.dev/vulnerability/PYSEC-2020-108","https://github.com/scikit-learn/scikit-learn/issues/18891","https://github.com/cjlin1/libsvm/blob/9a3a9708926dec87d382c43b203f2ca19c2d56a0/svm.cpp#L2501","http://seclists.org/fulldisclosure/2020/Nov/44","http://packetstormsecurity.com/files/160281/SciKit-Learn-0.23.2-Denial-Of-Service.html","https://github.com/advisories/GHSA-jxfp-4rvq-9h9m"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"PYSEC-2020-108","url":"https://osv.dev/vulnerability/PYSEC-2020-108"}],"summary":"** DISPUTED ** svm_predict_values in svm.cpp in Libsvm v324, as used in scikit-learn 0.23.2 and other products, allows attackers to cause a denial of service (segmentation fault) via a crafted model S"}