{"action":"Upgrade ansible to 2.7.17 or later.","affected":[{"fixed":"2.7.17","introduced":"0"},{"fixed":"2.8.9","introduced":"2.8.0"},{"fixed":"2.9.6","introduced":"2.9.0"}],"component":"ansible","cve_ids":["CVE-2020-1740"],"ecosystem":"PyPI","epss":0.00363,"exploited":false,"fixed_versions":["2.7.17","2.8.9","2.9.6"],"ghsa_id":"GHSA-vcg8-98q8-g7mj","id":"tcs_01M5KG9DEM7242H0VX8FP8RKEZ","modified_at":"2023-11-08T04:02:41.272964Z","published_at":"2020-03-16T16:15:00Z","references":["https://osv.dev/vulnerability/PYSEC-2020-12","https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2020-1740","https://github.com/ansible/ansible/issues/67798","https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/DKPA4KC3OJSUFASUYMG66HKJE7ADNGFW/","https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/WQVOQD4VAIXXTVQAJKTN7NUGTJFE2PCB/","https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/MRRYUU5ZBLPBXCYG6CFP35D64NP2UB2S/","https://lists.debian.org/debian-lts-announce/2020/05/msg00005.html","https://security.gentoo.org/glsa/202006-11","https://github.com/advisories/GHSA-vcg8-98q8-g7mj"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"PYSEC-2020-12","url":"https://osv.dev/vulnerability/PYSEC-2020-12"}],"summary":"A flaw was found in Ansible Engine when using Ansible Vault for editing encrypted files. When a user executes \"ansible-vault edit\", another user on the same computer can read the old and new secret, a"}