{"action":"Upgrade pip to 19.2 or later.","affected":[{"fixed":"19.2","introduced":"0"}],"component":"pip","cve_ids":["CVE-2019-20916"],"ecosystem":"PyPI","epss":0.03003,"exploited":false,"fixed_versions":["19.2"],"ghsa_id":"GHSA-gpvv-69j7-gwj8","id":"tcs_01M5KG9P35V7MRWZQZSNF428P2","modified_at":"2023-11-08T04:01:31.361287Z","published_at":"2020-09-04T20:15:00Z","references":["https://osv.dev/vulnerability/PYSEC-2020-173","https://github.com/pypa/pip/issues/6413","https://github.com/gzpan123/pip/commit/a4c735b14a62f9cb864533808ac63936704f2ace","https://github.com/pypa/pip/compare/19.1.1...19.2","https://lists.debian.org/debian-lts-announce/2020/09/msg00010.html","http://lists.opensuse.org/opensuse-security-announce/2020-10/msg00005.html","http://lists.opensuse.org/opensuse-security-announce/2020-10/msg00010.html","https://github.com/advisories/GHSA-gpvv-69j7-gwj8"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"PYSEC-2020-173","url":"https://osv.dev/vulnerability/PYSEC-2020-173"}],"summary":"The pip package before 19.2 for Python allows Directory Traversal when a URL is given in an install command, because a Content-Disposition header can have ../ in a filename, as demonstrated by overwri"}