{"action":"Upgrade ansible to 1.5.4 or later.","affected":[{"fixed":"1.5.4","introduced":"0"}],"component":"ansible","cve_ids":["CVE-2014-4657"],"ecosystem":"PyPI","epss":0.04427,"exploited":false,"fixed_versions":["1.5.4"],"ghsa_id":"GHSA-qg47-5px9-32g7","id":"tcs_01M5KG9QSNNPV7PHSFZ0P6AJHX","modified_at":"2026-06-10T17:00:05.436495826Z","published_at":"2020-02-20T15:15:00Z","references":["https://osv.dev/vulnerability/PYSEC-2020-199","https://www.securityfocus.com/bid/68232","https://github.com/ansible/ansible/blob/release1.5.5/CHANGELOG.md","https://github.com/advisories/GHSA-qg47-5px9-32g7"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"PYSEC-2020-199","url":"https://osv.dev/vulnerability/PYSEC-2020-199"}],"summary":"The safe_eval function in Ansible before 1.5.4 does not properly restrict the code subset, which allows remote attackers to execute arbitrary code via crafted instructions."}