{"action":"Upgrade ansible to 1.5.5 or later.","affected":[{"fixed":"1.5.5","introduced":"0"}],"component":"ansible","cve_ids":["CVE-2014-4658"],"ecosystem":"PyPI","epss":0.00418,"exploited":false,"fixed_versions":["1.5.5"],"ghsa_id":"GHSA-5g4v-2pc6-4hh4","id":"tcs_01M5KG9R99MFKKEJSC1P47NWVS","modified_at":"2026-06-10T17:00:05.494769942Z","published_at":"2020-02-20T15:15:00Z","references":["https://osv.dev/vulnerability/PYSEC-2020-200","https://www.securityfocus.com/bid/68233","https://github.com/ansible/ansible/blob/release1.5.5/CHANGELOG.md","https://github.com/advisories/GHSA-5g4v-2pc6-4hh4"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"PYSEC-2020-200","url":"https://osv.dev/vulnerability/PYSEC-2020-200"}],"summary":"The vault subsystem in Ansible before 1.5.5 does not set the umask before creation or modification of a vault file, which allows local users to obtain sensitive key information by reading a file."}