{"action":"Upgrade ansible to 1.6.4 or later.","affected":[{"fixed":"1.6.4","introduced":"0"}],"component":"ansible","cve_ids":["CVE-2014-4678"],"ecosystem":"PyPI","epss":0.05341,"exploited":false,"fixed_versions":["1.6.4"],"ghsa_id":"GHSA-66c7-5pwv-mm3j","id":"tcs_01M5KG9RQPMQ2Y2C7N6VN3XHAG","modified_at":"2026-06-10T17:00:06.824202445Z","published_at":"2020-02-20T03:15:00Z","references":["https://osv.dev/vulnerability/PYSEC-2020-203","https://www.rapid7.com/db/vulnerabilities/freebsd-vid-2c493ac8-205e-11e5-a4a5-002590263bf5","https://www.rapid7.com/db/vulnerabilities/gentoo-linux-cve-2014-4678","https://www.openwall.com/lists/oss-security/2014/07/02/2","https://security-tracker.debian.org/tracker/CVE-2014-4678","https://www.openwall.com/lists/oss-security/2014/06/26/30","https://github.com/ansible/ansible/commit/5429b85b9f6c2e640074176f36ff05fd5e4d1916","https://groups.google.com/forum/message/raw?msg=ansible-announce/ieV1vZvcTXU/5Q93ThkY9rIJ","https://github.com/advisories/GHSA-66c7-5pwv-mm3j"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"PYSEC-2020-203","url":"https://osv.dev/vulnerability/PYSEC-2020-203"},{"source":"nvd","source_id":"CVE-2014-4678","url":"https://nvd.nist.gov/vuln/detail/CVE-2014-4678"}],"summary":"The safe_eval function in Ansible before 1.6.4 does not properly restrict the code subset, which allows remote attackers to execute arbitrary code via crafted instructions. NOTE: this vulnerability ex"}