{"action":"Upgrade matrix-synapse to 1.21.0 or later.","affected":[{"fixed":"1.21.0","introduced":"0"}],"component":"matrix-synapse","cve_ids":["CVE-2020-26891"],"ecosystem":"PyPI","epss":0.01923,"exploited":false,"fixed_versions":["1.21.0"],"ghsa_id":"GHSA-3x8c-fmpc-5rmq","id":"tcs_01M5KG9Z8YWBDS0MM3J0SK63TX","modified_at":"2023-11-08T04:03:20.342815Z","published_at":"2020-10-19T17:15:00Z","references":["https://osv.dev/vulnerability/PYSEC-2020-238","https://matrix.org/blog/2020/10/15/synapse-1-21-2-released-and-security-advisory","https://github.com/matrix-org/synapse/pull/8444","https://github.com/matrix-org/synapse/releases/tag/v1.21.2","https://github.com/matrix-org/synapse/security/advisories/GHSA-3x8c-fmpc-5rmq"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"PYSEC-2020-238","url":"https://osv.dev/vulnerability/PYSEC-2020-238"}],"summary":"AuthRestServlet in Matrix Synapse before 1.21.0 is vulnerable to XSS due to unsafe interpolation of the session GET parameter. This allows a remote attacker to execute an XSS attack on the domain Syna"}