{"action":"Upgrade github.com/consensys/gnark to 0.14.0 or later.","affected":[{"fixed":"0.14.0","introduced":"0"}],"component":"github.com/consensys/gnark","cve_ids":["CVE-2025-57801"],"ecosystem":"Go","epss":0.00213,"exploited":false,"fixed_versions":["0.14.0"],"ghsa_id":"GHSA-95v9-hv42-pwrj","id":"tcs_01M5KGA3MN3CDE0EK84HPY1G01","modified_at":"2026-03-03T04:56:52.514084Z","published_at":"2025-08-29T14:52:35Z","references":["https://osv.dev/vulnerability/GO-2025-3912","https://github.com/Consensys/gnark/security/advisories/GHSA-95v9-hv42-pwrj","https://github.com/Consensys/gnark/commit/0ba6730f05537a351517998add89a61a0d82716e"],"severity":{"label":"critical","score":9.1},"sources":[{"source":"osv","source_id":"GO-2025-3912","url":"https://osv.dev/vulnerability/GO-2025-3912"},{"source":"nvd","source_id":"CVE-2025-57801","url":"https://nvd.nist.gov/vuln/detail/CVE-2025-57801"}],"summary":"Gnark is vulnerable to signature malleability in EdDSA and ECDSA due to missing scalar checks in github.com/consensys/gnark"}