{"action":"Upgrade tensorflow-gpu to 1.15.4 or later.","affected":[{"fixed":"1.15.4","introduced":"0"},{"fixed":"2.0.3","introduced":"2.0.0"},{"fixed":"2.1.2","introduced":"2.1.0"},{"fixed":"2.2.1","introduced":"2.2.0"},{"fixed":"2.3.1","introduced":"2.3.0"}],"component":"tensorflow-gpu","cve_ids":["CVE-2020-15205"],"ecosystem":"PyPI","epss":0.01029,"exploited":false,"fixed_versions":["1.15.4","2.0.3","2.1.2","2.2.1","2.3.1"],"ghsa_id":"GHSA-g7p5-5759-qv46","id":"tcs_01M5KGAFHCDX8NKZNSDNMT7843","modified_at":"2023-12-06T01:00:16.942992Z","published_at":"2020-09-25T19:15:00Z","references":["https://osv.dev/vulnerability/PYSEC-2020-320","https://github.com/tensorflow/tensorflow/security/advisories/GHSA-g7p5-5759-qv46","https://github.com/tensorflow/tensorflow/releases/tag/v2.3.1","https://github.com/tensorflow/tensorflow/commit/0462de5b544ed4731aa2fb23946ac22c01856b80","http://lists.opensuse.org/opensuse-security-announce/2020-10/msg00065.html"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"PYSEC-2020-320","url":"https://osv.dev/vulnerability/PYSEC-2020-320"}],"summary":"In Tensorflow before versions 1.15.4, 2.0.3, 2.1.2, 2.2.1 and 2.3.1, the `data_splits` argument of `tf.raw_ops.StringNGrams` lacks validation. This allows a user to pass values that can cause heap ove"}