{"action":"Upgrade @vitejs/plugin-rsc to 0.5.23 or later.","affected":[{"fixed":"0.5.23","introduced":"0"}],"component":"@vitejs/plugin-rsc","cve_ids":[],"ecosystem":"npm","exploited":false,"fixed_versions":["0.5.23"],"ghsa_id":"GHSA-v457-wxvj-p9w9","id":"tcs_01M5KGAP7DZEGVCKWRPX4M0R7Z","modified_at":"2026-04-10T15:49:39.998734Z","published_at":"2026-04-10T15:36:00Z","references":["https://osv.dev/vulnerability/GHSA-v457-wxvj-p9w9","https://github.com/vitejs/vite-plugin-react/security/advisories/GHSA-v457-wxvj-p9w9","https://github.com/vitejs/vite-plugin-react"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"GHSA-v457-wxvj-p9w9","url":"https://osv.dev/vulnerability/GHSA-v457-wxvj-p9w9"}],"summary":"@vitejs/plugin-rsc has a Denial of Service with React Server Components"}