{"action":"Upgrade oic to 1.2.1 or later.","affected":[{"fixed":"1.2.1","introduced":"0"}],"component":"oic","cve_ids":["CVE-2020-26244"],"ecosystem":"PyPI","epss":0.00832,"exploited":false,"fixed_versions":["1.2.1"],"ghsa_id":"GHSA-4fjv-pmhg-3rfg","id":"tcs_01M5KGATCAW4BBFE11W4BNRNRG","modified_at":"2023-11-08T04:03:15.948349Z","published_at":"2020-12-02T20:15:00Z","references":["https://osv.dev/vulnerability/PYSEC-2020-69","https://github.com/OpenIDC/pyoidc/security/advisories/GHSA-4fjv-pmhg-3rfg","https://github.com/OpenIDC/pyoidc/commit/62f8d753fa17c8b1f29f8be639cf0b33afb02498","https://pypi.org/project/oic/","https://github.com/OpenIDC/pyoidc/releases/tag/1.2.1"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"PYSEC-2020-69","url":"https://osv.dev/vulnerability/PYSEC-2020-69"}],"summary":"Python oic is a Python OpenID Connect implementation. In Python oic before version 1.2.1, there are several related cryptographic issues affecting client implementations that use the library. The issu"}