{"action":"Upgrade openapi-python-client to 0.5.3 or later.","affected":[{"fixed":"0.5.3","introduced":"0"}],"component":"openapi-python-client","cve_ids":["CVE-2020-15142"],"ecosystem":"PyPI","epss":0.01849,"exploited":false,"fixed_versions":["0.5.3"],"ghsa_id":"GHSA-9x4c-63pf-525f","id":"tcs_01M5KGAV5GPJPM8K86QWS4MES7","modified_at":"2023-11-08T04:02:31.004919Z","published_at":"2020-08-14T17:15:00Z","references":["https://osv.dev/vulnerability/PYSEC-2020-71","https://github.com/triaxtec/openapi-python-client/blob/main/CHANGELOG.md#053---2020-08-13","https://pypi.org/project/openapi-python-client/","https://github.com/triaxtec/openapi-python-client/commit/f7a56aae32cba823a77a84a1f10400799b19c19a","https://github.com/triaxtec/openapi-python-client/security/advisories/GHSA-9x4c-63pf-525f"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"PYSEC-2020-71","url":"https://osv.dev/vulnerability/PYSEC-2020-71"}],"summary":"In openapi-python-client before version 0.5.3, clients generated with a maliciously crafted OpenAPI Document can generate arbitrary Python code. Subsequent execution of this malicious client is arbitr"}