{"action":"Upgrade next-auth to 4.24.5 or later.","affected":[{"fixed":"4.24.5","introduced":"0"}],"component":"next-auth","cve_ids":["CVE-2023-48309"],"ecosystem":"npm","epss":0.007,"exploited":false,"fixed_versions":["4.24.5"],"ghsa_id":"GHSA-v64w-49xw-qq89","id":"tcs_01M5KGAY2GFKTJR6W37P4J3P8Q","modified_at":"2026-09-10T03:49:59.122075128Z","published_at":"2023-11-20T23:25:36Z","references":["https://osv.dev/vulnerability/GHSA-v64w-49xw-qq89","https://github.com/nextauthjs/next-auth/security/advisories/GHSA-v64w-49xw-qq89","https://nvd.nist.gov/vuln/detail/CVE-2023-48309","https://github.com/nextauthjs/next-auth/commit/d237059b6d0cb868c041ba18b698e0cee20a2f10","https://authjs.dev/guides/basics/role-based-access-control","https://github.com/nextauthjs/next-auth","https://next-auth.js.org/configuration/nextjs#advanced-usage","https://next-auth.js.org/configuration/nextjs#middlewar"],"severity":{"label":"medium","score":5.3},"sources":[{"source":"osv","source_id":"GHSA-v64w-49xw-qq89","url":"https://osv.dev/vulnerability/GHSA-v64w-49xw-qq89"}],"summary":"Possible user mocking that bypasses basic authentication"}