{"action":"Upgrade py to 1.10.0 or later.","affected":[{"fixed":"1.10.0","introduced":"0"}],"component":"py","cve_ids":["CVE-2020-29651"],"ecosystem":"PyPI","epss":0.04662,"exploited":false,"fixed_versions":["1.10.0"],"ghsa_id":"GHSA-hj5v-574p-mj7c","id":"tcs_01M5KGAZ3YE79MDEZB4R3801DN","modified_at":"2023-11-08T04:03:31.657020Z","published_at":"2020-12-09T07:15:00Z","references":["https://osv.dev/vulnerability/PYSEC-2020-92","https://github.com/pytest-dev/py/pull/257/commits/4a9017dc6199d2a564b6e4b0aa39d6d8870e4144","https://github.com/pytest-dev/py/issues/256","https://github.com/pytest-dev/py/pull/257","https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/AYWNYEV3FGDHPIHX4DDUDMFZ6NLCQRC4/","https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/CHDTINIBJZ67T3W74QTBIY5LPKAXEOGR/","https://github.com/advisories/GHSA-hj5v-574p-mj7c"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"PYSEC-2020-92","url":"https://osv.dev/vulnerability/PYSEC-2020-92"}],"summary":"A denial of service via regular expression in the py.path.svnwc component of py (aka python-py) through 1.9.0 could be used by attackers to cause a compute-time denial of service attack by supplying m"}