{"action":"Upgrade @frontmcp/sdk to 1.0.4 or later.","affected":[{"fixed":"1.0.4","introduced":"0"}],"component":"@frontmcp/sdk","cve_ids":["CVE-2026-39885"],"ecosystem":"npm","epss":0.00396,"exploited":false,"fixed_versions":["1.0.4"],"ghsa_id":"GHSA-v6ph-xcq9-qxxj","id":"tcs_01M5KGB15KG0FSSZFE7250PCV2","modified_at":"2026-04-09T14:47:24.272767Z","published_at":"2026-04-08T19:22:53Z","references":["https://osv.dev/vulnerability/GHSA-v6ph-xcq9-qxxj","https://github.com/agentfront/frontmcp/security/advisories/GHSA-v6ph-xcq9-qxxj","https://nvd.nist.gov/vuln/detail/CVE-2026-39885","https://github.com/agentfront/frontmcp","https://github.com/agentfront/frontmcp/releases/tag/v1.0.4"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"GHSA-v6ph-xcq9-qxxj#npm/@frontmcp/sdk","url":"https://osv.dev/vulnerability/GHSA-v6ph-xcq9-qxxj"}],"summary":"mcp-from-openapi is Vulnerable to SSRF via $ref Dereferencing in Untrusted OpenAPI Specifications"}