{"action":"Upgrade zope to 4.6.1 or later.","affected":[{"fixed":"4.6.1","introduced":"4.0"},{"fixed":"5.2.1","introduced":"5.0"}],"component":"zope","cve_ids":["CVE-2021-32674"],"ecosystem":"PyPI","epss":0.01587,"exploited":false,"fixed_versions":["4.6.1","5.2.1"],"ghsa_id":"GHSA-5vq5-pg3r-9ph3","id":"tcs_01M5KGB1EEKW3H8RETRFA85TPN","modified_at":"2026-07-09T16:56:40.219514949Z","published_at":"2021-06-08T18:15:00Z","references":["https://osv.dev/vulnerability/PYSEC-2021-104","https://github.com/zopefoundation/Zope/security/advisories/GHSA-rpcg-f9q6-2mq6","https://github.com/zopefoundation/Zope/commit/1d897910139e2c0b11984fc9b78c1da1365bec21","https://pypi.org/project/Zope/","https://github.com/advisories/GHSA-rpcg-f9q6-2mq6"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"PYSEC-2021-104","url":"https://osv.dev/vulnerability/PYSEC-2021-104"}],"summary":"Zope is an open-source web application server. This advisory extends the previous advisory at https://github.com/zopefoundation/Zope/security/advisories/GHSA-5pr9-v234-jw36 with additional cases of TA"}