{"action":"Upgrade tensorflow to 2.1.4 or later.","affected":[{"fixed":"2.1.4","introduced":"0"},{"fixed":"2.2.3","introduced":"2.2.0"},{"fixed":"2.3.3","introduced":"2.3.0"},{"fixed":"2.4.2","introduced":"2.4.0"}],"component":"tensorflow","cve_ids":["CVE-2021-29591"],"ecosystem":"PyPI","epss":0.00262,"exploited":false,"fixed_versions":["2.1.4","2.2.3","2.3.3","2.4.2"],"ghsa_id":"GHSA-cwv3-863g-39vx","id":"tcs_01M5KGBSM399MRXKXW7G5KCF00","modified_at":"2023-12-06T01:01:08.095708Z","published_at":"2021-05-14T20:15:00Z","references":["https://osv.dev/vulnerability/PYSEC-2021-228","https://github.com/tensorflow/tensorflow/security/advisories/GHSA-cwv3-863g-39vx","https://github.com/tensorflow/tensorflow/commit/9c1dc920d8ffb4893d6c9d27d1f039607b326743","https://github.com/tensorflow/tensorflow/commit/c6173f5fe66cdbab74f4f869311fe6aae2ba35f4"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"PYSEC-2021-228","url":"https://osv.dev/vulnerability/PYSEC-2021-228"}],"summary":"TensorFlow is an end-to-end open source platform for machine learning. TFlite graphs must not have loops between nodes. However, this condition was not checked and an attacker could craft models that"}