{"action":"Upgrade node-opcua to 2.74.0 or later.","affected":[{"fixed":"2.74.0","introduced":"0"}],"component":"node-opcua","cve_ids":["CVE-2022-24375"],"ecosystem":"npm","epss":0.01671,"exploited":false,"fixed_versions":["2.74.0"],"ghsa_id":"GHSA-vh4f-fgpp-x8x2","id":"tcs_01M5KGBXW7VRFDQ5YEASP4Z9KE","modified_at":"2023-11-08T04:08:30.926023Z","published_at":"2022-08-25T00:00:29Z","references":["https://osv.dev/vulnerability/GHSA-vh4f-fgpp-x8x2","https://nvd.nist.gov/vuln/detail/CVE-2022-24375","https://github.com/node-opcua/node-opcua/pull/1182","https://github.com/node-opcua/node-opcua/commit/3fd46ec156e7718a506be41f3916310b6bdd0407","https://github.com/node-opcua/node-opcua/commit/7b5044b3f5866fbedc3efabd05e407352c07bd2f","https://github.com/node-opcua/node-opcua","https://security.snyk.io/vuln/SNYK-JS-NODEOPCUA-2988725"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"GHSA-vh4f-fgpp-x8x2","url":"https://osv.dev/vulnerability/GHSA-vh4f-fgpp-x8x2"}],"summary":"node-opcua DoS when bypassing limitations for excessive memory consumption"}