{"action":"Upgrade dompurify to 3.2.4 or later.","affected":[{"fixed":"3.2.4","introduced":"0"}],"component":"dompurify","cve_ids":["CVE-2025-26791"],"ecosystem":"npm","epss":0.00605,"exploited":false,"fixed_versions":["3.2.4"],"ghsa_id":"GHSA-vhxf-7vqr-mrjg","id":"tcs_01M5KGC2W0RR3RZFYKQCKR05FA","modified_at":"2026-09-10T03:50:06.152680854Z","published_at":"2025-02-14T09:31:22Z","references":["https://osv.dev/vulnerability/GHSA-vhxf-7vqr-mrjg","https://nvd.nist.gov/vuln/detail/CVE-2025-26791","https://github.com/cure53/DOMPurify/commit/d18ffcb554e0001748865da03ac75dd7829f0f02","https://ensy.zip/posts/dompurify-323-bypass","https://github.com/cure53/DOMPurify","https://github.com/cure53/DOMPurify/releases/tag/3.2.4","https://nsysean.github.io/posts/dompurify-323-bypass"],"severity":{"label":"medium","score":4.5},"sources":[{"source":"osv","source_id":"GHSA-vhxf-7vqr-mrjg","url":"https://osv.dev/vulnerability/GHSA-vhxf-7vqr-mrjg"}],"summary":"DOMPurify allows Cross-site Scripting (XSS)"}