{"action":"Upgrade flask-restx to 0.5.1 or later.","affected":[{"fixed":"0.5.1","introduced":"0"}],"component":"flask-restx","cve_ids":["CVE-2021-32838"],"ecosystem":"PyPI","epss":0.01864,"exploited":false,"fixed_versions":["0.5.1"],"ghsa_id":"GHSA-3q6g-vf58-7m4g","id":"tcs_01M5KGCC6BCB4RRXWJ7MTETACF","modified_at":"2023-11-08T04:06:01.923801Z","published_at":"2021-09-20T18:15:00Z","references":["https://osv.dev/vulnerability/PYSEC-2021-325","https://github.com/python-restx/flask-restx/issues/372","https://pypi.org/project/flask-restx/","https://github.com/python-restx/flask-restx/commit/bab31e085f355dd73858fd3715f7ed71849656da","https://github.com/advisories/GHSA-3q6g-vf58-7m4g","https://github.com/python-restx/flask-restx/blob/fd99fe11a88531f5f3441a278f7020589f9d2cc0/flask_restx/inputs.py#L51"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"PYSEC-2021-325","url":"https://osv.dev/vulnerability/PYSEC-2021-325"}],"summary":"Flask-RESTX (pypi package flask-restx) is a community driven fork of Flask-RESTPlus. Flask-RESTX before version 0.5.1 is vulnerable to ReDoS (Regular Expression Denial of Service) in email_regex. This"}