{"action":"Upgrade apache-airflow to 2.1.3 or later.","affected":[{"fixed":"2.1.3","introduced":"2.0.0"}],"component":"apache-airflow","cve_ids":["CVE-2021-38540"],"ecosystem":"PyPI","epss":0.80938,"exploited":false,"fixed_versions":["2.1.3"],"ghsa_id":"GHSA-h88f-r7cw-8fv3","id":"tcs_01M5KGCCBNCEGC62KQCQ6NG6V5","modified_at":"2023-12-06T01:01:25.686699Z","published_at":"2021-09-09T15:15:00Z","references":["https://osv.dev/vulnerability/PYSEC-2021-326","https://lists.apache.org/thread.html/rb34c3dd1a815456355217eef34060789f771b6f77c3a3dec77de2064%40%3Cusers.airflow.apache.org%3E","https://lists.apache.org/thread.html/rac2ed9118f64733e47b4f1e82ddc8c8020774698f13328ca742b03a2@%3Cannounce.apache.org%3E","https://github.com/advisories/GHSA-h88f-r7cw-8fv3"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"PYSEC-2021-326","url":"https://osv.dev/vulnerability/PYSEC-2021-326"}],"summary":"The variable import endpoint was not protected by authentication in Airflow >=2.0.0, <2.1.3. This allowed unauthenticated users to hit that endpoint to add/modify Airflow variables used in DAGs, poten"}