{"action":"Upgrade sqlparse to 0.4.2 or later.","affected":[{"fixed":"0.4.2","introduced":"0.4.0"}],"component":"sqlparse","cve_ids":["CVE-2021-32839"],"ecosystem":"PyPI","epss":0.02339,"exploited":false,"fixed_versions":["0.4.2"],"ghsa_id":"GHSA-p5w8-wqhj-9hhf","id":"tcs_01M5KGCDZAJB015Q9BQK5R4241","modified_at":"2023-11-08T04:06:01.984949Z","published_at":"2021-09-20T17:15:00Z","references":["https://osv.dev/vulnerability/PYSEC-2021-333","https://github.com/andialbrecht/sqlparse/commit/8238a9e450ed1524e40cb3a8b0b3c00606903aeb","https://github.com/andialbrecht/sqlparse/security/advisories/GHSA-p5w8-wqhj-9hhf"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"PYSEC-2021-333","url":"https://osv.dev/vulnerability/PYSEC-2021-333"}],"summary":"sqlparse is a non-validating SQL parser module for Python. In sqlparse versions 0.4.0 and 0.4.1 there is a regular Expression Denial of Service in sqlparse vulnerability. The regular expression may ca"}