{"action":"Upgrade esphome to 2021.9.2 or later.","affected":[{"fixed":"2021.9.2","introduced":"0"}],"component":"esphome","cve_ids":["CVE-2021-41104"],"ecosystem":"PyPI","epss":0.01213,"exploited":false,"fixed_versions":["2021.9.2"],"ghsa_id":"GHSA-48mj-p7x2-5jfm","id":"tcs_01M5KGCHDGXGE8BV5HBJMJMHCP","modified_at":"2023-11-08T04:06:51.299405Z","published_at":"2021-09-28T16:15:00Z","references":["https://osv.dev/vulnerability/PYSEC-2021-351","https://github.com/esphome/esphome/commit/2234f6aacf8cc653307fed80f3750317a82c4f83","https://github.com/esphome/esphome/pull/2409/commits/207cde1667d8c799a197b78ca8a5a14de8d5ca1e","https://github.com/esphome/esphome/releases/tag/2021.9.2","https://github.com/esphome/esphome/security/advisories/GHSA-48mj-p7x2-5jfm"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"PYSEC-2021-351","url":"https://osv.dev/vulnerability/PYSEC-2021-351"}],"summary":"ESPHome is a system to control the ESP8266/ESP32. Anyone with web_server enabled and HTTP basic auth configured on version 2021.9.1 or older is vulnerable to an issue in which `web_server` allows over"}