{"action":"Upgrade scrapy to 1.8.1 or later.","affected":[{"fixed":"1.8.1","introduced":"0"},{"fixed":"2.5.1","introduced":"2.0.0"}],"component":"scrapy","cve_ids":["CVE-2021-41125"],"ecosystem":"PyPI","epss":0.01261,"exploited":false,"fixed_versions":["1.8.1","2.5.1"],"ghsa_id":"GHSA-jwqp-28gf-p498","id":"tcs_01M5KGCKCBW9EZW44WE4EWT22B","modified_at":"2023-11-08T04:06:52.040115Z","published_at":"2021-10-06T18:15:00Z","references":["https://osv.dev/vulnerability/PYSEC-2021-363","https://github.com/scrapy/scrapy/commit/b01d69a1bf48060daec8f751368622352d8b85a6","https://w3lib.readthedocs.io/en/latest/w3lib.html#w3lib.http.basic_auth_header","https://github.com/scrapy/scrapy/security/advisories/GHSA-jwqp-28gf-p498","http://doc.scrapy.org/en/latest/topics/downloader-middleware.html#module-scrapy.downloadermiddlewares.httpauth"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"PYSEC-2021-363","url":"https://osv.dev/vulnerability/PYSEC-2021-363"}],"summary":"Scrapy is a high-level web crawling and scraping framework for Python. If you use `HttpAuthMiddleware` (i.e. the `http_user` and `http_pass` spider attributes) for HTTP authentication, all requests wi"}