{"action":"Upgrade vyper to 0.3.0 or later.","affected":[{"fixed":"0.3.0","introduced":"0"}],"component":"vyper","cve_ids":["CVE-2021-41122"],"ecosystem":"PyPI","epss":0.00803,"exploited":false,"fixed_versions":["0.3.0"],"ghsa_id":"GHSA-c7pr-343r-5c46","id":"tcs_01M5KGCM6D7N80G0F17YET9V35","modified_at":"2023-11-08T04:06:51.916176Z","published_at":"2021-10-05T23:15:00Z","references":["https://osv.dev/vulnerability/PYSEC-2021-366","https://github.com/vyperlang/vyper/security/advisories/GHSA-c7pr-343r-5c46","https://github.com/vyperlang/vyper/pull/2447"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"PYSEC-2021-366","url":"https://osv.dev/vulnerability/PYSEC-2021-366"}],"summary":"Vyper is a Pythonic Smart Contract Language for the EVM. In affected versions external functions did not properly validate the bounds of decimal arguments. The can lead to logic errors. This issue has"}