{"action":"Upgrade zope to 4.6.3 or later.","affected":[{"fixed":"4.6.3","introduced":"4.0"},{"fixed":"5.3","introduced":"5.0"}],"component":"zope","cve_ids":["CVE-2021-32811"],"ecosystem":"PyPI","epss":0.02296,"exploited":false,"fixed_versions":["4.6.3","5.3"],"ghsa_id":"GHSA-g4gq-j4p2-j8fr","id":"tcs_01M5KGCMAZ2DTZ7KNK6S2M3966","modified_at":"2026-07-09T16:56:40.110056749Z","published_at":"2021-08-02T22:15:00Z","references":["https://osv.dev/vulnerability/PYSEC-2021-368","https://github.com/zopefoundation/Zope/security/advisories/GHSA-g4gq-j4p2-j8fr","https://github.com/zopefoundation/Zope/commit/f72a18dda8e9bf2aedb46168761668464a4be988"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"PYSEC-2021-368","url":"https://osv.dev/vulnerability/PYSEC-2021-368"}],"summary":"Zope is an open-source web application server. Zope versions prior to versions 4.6.3 and 5.3 have a remote code execution security issue. In order to be affected, one must use Python 3 for one's Zope"}