{"action":"Upgrade cobbler to 3.3.0 or later.","affected":[{"fixed":"3.3.0","introduced":"0"}],"component":"cobbler","cve_ids":["CVE-2021-40324"],"ecosystem":"PyPI","epss":0.68635,"exploited":false,"fixed_versions":["3.3.0"],"ghsa_id":"GHSA-4cfr-gjfx-fj3x","id":"tcs_01M5KGCNEZV0S0QMNCV6Q1G0GS","modified_at":"2025-10-09T07:55:28.834386Z","published_at":"2021-10-04T06:15:00Z","references":["https://osv.dev/vulnerability/PYSEC-2021-374","https://github.com/cobbler/cobbler/commit/d8f60bbf14a838c8c8a1dba98086b223e35fe70a","https://github.com/cobbler/cobbler/releases/tag/v3.3.0","https://github.com/advisories/GHSA-4cfr-gjfx-fj3x"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"PYSEC-2021-374","url":"https://osv.dev/vulnerability/PYSEC-2021-374"}],"summary":"Cobbler before 3.3.0 allows arbitrary file write operations via upload_log_data."}