{"action":"Upgrade nodebb to 3.11.1 or later.","affected":[{"fixed":"3.11.1","introduced":"0"}],"component":"nodebb","cve_ids":["CVE-2024-57041"],"ecosystem":"npm","epss":0.40107,"exploited":false,"fixed_versions":["3.11.1"],"ghsa_id":"GHSA-vqr3-vrrg-f3jh","id":"tcs_01M5KGCQEQ8XENA8Q7G28PWAYN","modified_at":"2025-02-07T20:56:59.110416Z","published_at":"2025-01-24T21:31:27Z","references":["https://osv.dev/vulnerability/GHSA-vqr3-vrrg-f3jh","https://nvd.nist.gov/vuln/detail/CVE-2024-57041","https://github.com/NodeBB/NodeBB/commit/4e69bff72fd04779064d37e46a43080e6c328adf","https://github.com/NodeBB/NodeBB","https://www.tonysec.com/posts/cve-2024-57041"],"severity":{"label":"medium","score":4.6},"sources":[{"source":"osv","source_id":"GHSA-vqr3-vrrg-f3jh","url":"https://osv.dev/vulnerability/GHSA-vqr3-vrrg-f3jh"}],"summary":"NodeBB Cross-site scripting (XSS) vulnerability"}