{"action":"Upgrade apache-airflow to 1.10.15 or later.","affected":[{"fixed":"1.10.15","introduced":"1.8.1"},{"fixed":"2.0.2","introduced":"2.0.0"}],"component":"apache-airflow","cve_ids":["CVE-2021-28359"],"ecosystem":"PyPI","epss":0.14389,"exploited":false,"fixed_versions":["1.10.15","2.0.2"],"ghsa_id":"GHSA-3xxv-p78r-4fc6","id":"tcs_01M5KGCTEMP3TV0GPG5FNK93QN","modified_at":"2023-12-06T01:01:00.818677Z","published_at":"2021-05-02T08:15:00Z","references":["https://osv.dev/vulnerability/PYSEC-2021-4","https://lists.apache.org/thread.html/ra8ce70088ba291f358e077cafdb14d174b7a1ce9a9d86d1b332d6367%40%3Cusers.airflow.apache.org%3E","https://lists.apache.org/thread.html/rc005f4de9d9b0ba943ceb8ff5a21a5c6ff8a9df52632476698d99432@%3Cannounce.apache.org%3E","https://github.com/advisories/GHSA-3xxv-p78r-4fc6"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"PYSEC-2021-4","url":"https://osv.dev/vulnerability/PYSEC-2021-4"}],"summary":"The \"origin\" parameter passed to some of the endpoints like '/trigger' was vulnerable to XSS exploit. This issue affects Apache Airflow versions <1.10.15 in 1.x series and affects 2.0.0 and 2.0.1 and"}