{"action":"Upgrade tensorflow to 2.4.4 or later.","affected":[{"fixed":"2.4.4","introduced":"0"},{"fixed":"2.5.2","introduced":"2.5.0"},{"fixed":"2.6.1","introduced":"2.6.0"},{"fixed":"2.7.0","introduced":"2.7.0rc0"}],"component":"tensorflow","cve_ids":["CVE-2021-41228"],"ecosystem":"PyPI","epss":0.00217,"exploited":false,"fixed_versions":["2.4.4","2.5.2","2.6.1","2.7.0"],"ghsa_id":"GHSA-3rcw-9p9x-582v","id":"tcs_01M5KGCYVSXP1SAGPF491S6G8P","modified_at":"2023-12-06T01:01:35.429977Z","published_at":"2021-11-05T23:15:00Z","references":["https://osv.dev/vulnerability/PYSEC-2021-420","https://github.com/tensorflow/tensorflow/commit/8b202f08d52e8206af2bdb2112a62fafbc546ec7","https://github.com/tensorflow/tensorflow/security/advisories/GHSA-3rcw-9p9x-582v"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"PYSEC-2021-420","url":"https://osv.dev/vulnerability/PYSEC-2021-420"}],"summary":"TensorFlow is an open source platform for machine learning. In affected versions TensorFlow's `saved_model_cli` tool is vulnerable to a code injection as it calls `eval` on user supplied strings. This"}