{"action":"Upgrade pip to 21.1 or later.","affected":[{"fixed":"21.1","introduced":"0"}],"component":"pip","cve_ids":["CVE-2021-3572"],"ecosystem":"PyPI","epss":0.01829,"exploited":false,"fixed_versions":["21.1"],"ghsa_id":"GHSA-5xp3-jfq3-5q8x","id":"tcs_01M5KGD1Q3Q0H68BGD2ZNEHCKJ","modified_at":"2026-03-24T01:42:38.485764Z","published_at":"2021-11-10T18:15:00Z","references":["https://osv.dev/vulnerability/PYSEC-2021-437","https://bugzilla.redhat.com/show_bug.cgi?id=1962856","https://github.com/advisories/GHSA-5xp3-jfq3-5q8x"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"PYSEC-2021-437","url":"https://osv.dev/vulnerability/PYSEC-2021-437"}],"summary":"A flaw was found in python-pip in the way it handled Unicode separators in git references. A remote attacker could possibly use this issue to install a different revision on a repository. The highest"}