{"action":"Upgrade tensorflow-cpu to 2.1.4 or later.","affected":[{"fixed":"2.1.4","introduced":"0"},{"fixed":"2.2.3","introduced":"2.2.0"},{"fixed":"2.3.3","introduced":"2.3.0"},{"fixed":"2.4.2","introduced":"2.4.0"}],"component":"tensorflow-cpu","cve_ids":["CVE-2021-29522"],"ecosystem":"PyPI","epss":0.00189,"exploited":false,"fixed_versions":["2.1.4","2.2.3","2.3.3","2.4.2"],"ghsa_id":"GHSA-c968-pq7h-7fxv","id":"tcs_01M5KGD4C6AHEDTN01GPSZV7S9","modified_at":"2023-12-06T01:01:03.799643Z","published_at":"2021-05-14T20:15:00Z","references":["https://osv.dev/vulnerability/PYSEC-2021-450","https://github.com/tensorflow/tensorflow/security/advisories/GHSA-c968-pq7h-7fxv","https://github.com/tensorflow/tensorflow/commit/311403edbc9816df80274bd1ea8b3c0c0f22c3fa"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"PYSEC-2021-450","url":"https://osv.dev/vulnerability/PYSEC-2021-450"}],"summary":"TensorFlow is an end-to-end open source platform for machine learning. The `tf.raw_ops.Conv3DBackprop*` operations fail to validate that the input tensors are not empty. In turn, this would result in"}