{"action":"Upgrade gettext.js to 2.0.3 or later.","affected":[{"fixed":"2.0.3","introduced":"0"}],"component":"gettext.js","cve_ids":["CVE-2024-43370"],"ecosystem":"npm","epss":0.0038,"exploited":false,"fixed_versions":["2.0.3"],"ghsa_id":"GHSA-vwhg-jwr4-vxgg","id":"tcs_01M5KGD50QHJ6HAQNTBS39P6JJ","modified_at":"2024-08-16T18:15:39Z","published_at":"2024-08-15T18:06:50Z","references":["https://osv.dev/vulnerability/GHSA-vwhg-jwr4-vxgg","https://github.com/guillaumepotier/gettext.js/security/advisories/GHSA-vwhg-jwr4-vxgg","https://nvd.nist.gov/vuln/detail/CVE-2024-43370","https://github.com/guillaumepotier/gettext.js/commit/8150aeba833183e14c2291a8a148b8f79d1d68d8","https://github.com/guillaumepotier/gettext.js"],"severity":{"label":"high","score":7.2},"sources":[{"source":"osv","source_id":"GHSA-vwhg-jwr4-vxgg","url":"https://osv.dev/vulnerability/GHSA-vwhg-jwr4-vxgg"}],"summary":"gettext.js has a Cross-site Scripting injection"}