{"action":"Upgrade proxy-py to 2.3.1 or later.","affected":[{"fixed":"2.3.1","introduced":"0"}],"component":"proxy-py","cve_ids":["CVE-2021-3116"],"ecosystem":"PyPI","epss":0.01694,"exploited":false,"fixed_versions":["2.3.1"],"ghsa_id":"GHSA-cmc7-mfmr-xqrx","id":"tcs_01M5KGD6A9A17J66V087TCJBX8","modified_at":"2023-11-08T04:05:47.192874Z","published_at":"2021-01-11T05:15:00Z","references":["https://osv.dev/vulnerability/PYSEC-2021-46","https://pypi.org/project/proxy.py/2.3.1/#history","https://cardaci.xyz/advisories/2021/01/10/proxy.py-2.3.0-broken-basic-authentication/","https://github.com/abhinavsingh/proxy.py/pull/482/commits/9b00093288237f5073c403f2c4f62acfdfa8ed46","https://github.com/advisories/GHSA-cmc7-mfmr-xqrx"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"PYSEC-2021-46","url":"https://osv.dev/vulnerability/PYSEC-2021-46"}],"summary":"before_upstream_connection in AuthPlugin in http/proxy/auth.py in proxy.py before 2.3.1 accepts incorrect Proxy-Authorization header data because of a boolean confusion (and versus or)."}