{"action":"Upgrade tensorflow-cpu to 2.2.0rc0 or later.","affected":[{"fixed":"2.2.0rc0","introduced":"0"},{"fixed":"2.3.0rc0","introduced":"2.2.0"},{"fixed":"2.3.4","introduced":"2.3.0"},{"fixed":"2.4.3","introduced":"2.4.0"}],"component":"tensorflow-cpu","cve_ids":["CVE-2021-29535"],"ecosystem":"PyPI","epss":0.00211,"exploited":false,"fixed_versions":["2.2.0rc0","2.3.0rc0","2.3.4","2.4.3"],"ghsa_id":"GHSA-m3f9-w3p3-p669","id":"tcs_01M5KGD6Z2SBQCKWHHKGDAK8Z7","modified_at":"2023-12-06T01:01:04.597075Z","published_at":"2021-05-14T20:15:00Z","references":["https://osv.dev/vulnerability/PYSEC-2021-463","https://github.com/tensorflow/tensorflow/security/advisories/GHSA-m3f9-w3p3-p669","https://github.com/tensorflow/tensorflow/commit/efea03b38fb8d3b81762237dc85e579cc5fc6e87"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"PYSEC-2021-463","url":"https://osv.dev/vulnerability/PYSEC-2021-463"}],"summary":"TensorFlow is an end-to-end open source platform for machine learning. An attacker can cause a heap buffer overflow in `QuantizedMul` by passing in invalid thresholds for the quantization. This is bec"}