{"action":"Upgrade tensorflow-cpu to 2.2.0rc0 or later.","affected":[{"fixed":"2.2.0rc0","introduced":"0"},{"fixed":"2.3.0rc0","introduced":"2.2.0"},{"fixed":"2.3.4","introduced":"2.3.0"},{"fixed":"2.4.3","introduced":"2.4.0"}],"component":"tensorflow-cpu","cve_ids":["CVE-2021-29545"],"ecosystem":"PyPI","epss":0.00189,"exploited":false,"fixed_versions":["2.2.0rc0","2.3.0rc0","2.3.4","2.4.3"],"ghsa_id":"GHSA-hmg3-c7xj-6qwm","id":"tcs_01M5KGD8R8BCZ3QW1162AJ1688","modified_at":"2023-12-06T01:01:05.200703Z","published_at":"2021-05-14T20:15:00Z","references":["https://osv.dev/vulnerability/PYSEC-2021-473","https://github.com/tensorflow/tensorflow/security/advisories/GHSA-hmg3-c7xj-6qwm","https://github.com/tensorflow/tensorflow/commit/1e922ccdf6bf46a3a52641f99fd47d54c1decd13"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"PYSEC-2021-473","url":"https://osv.dev/vulnerability/PYSEC-2021-473"}],"summary":"TensorFlow is an end-to-end open source platform for machine learning. An attacker can trigger a denial of service via a `CHECK`-fail in converting sparse tensors to CSR Sparse matrices. This is becau"}