{"action":"Upgrade pysaml2 to 6.5.0 or later.","affected":[{"fixed":"6.5.0","introduced":"0"}],"component":"pysaml2","cve_ids":["CVE-2021-21238"],"ecosystem":"PyPI","epss":0.01096,"exploited":false,"fixed_versions":["6.5.0"],"ghsa_id":"GHSA-f4g9-h89h-jgv9","id":"tcs_01M5KGDAFXB5XH5XQ4T4AT4H6H","modified_at":"2023-11-08T04:04:39.068101Z","published_at":"2021-01-21T15:15:00Z","references":["https://osv.dev/vulnerability/PYSEC-2021-48","https://pypi.org/project/pysaml2","https://github.com/IdentityPython/pysaml2/releases/tag/v6.5.0","https://github.com/IdentityPython/pysaml2/commit/1d8fd268f5bf887480a403a7a5ef8f048157cc14","https://github.com/IdentityPython/pysaml2/security/advisories/GHSA-f4g9-h89h-jgv9"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"PYSEC-2021-48","url":"https://osv.dev/vulnerability/PYSEC-2021-48"}],"summary":"PySAML2 is a pure python implementation of SAML Version 2 Standard. PySAML2 before 6.5.0 has an improper verification of cryptographic signature vulnerability. All users of pysaml2 that need to valida"}