{"action":"Upgrade tensorflow-cpu to 2.2.0rc0 or later.","affected":[{"fixed":"2.2.0rc0","introduced":"0"},{"fixed":"2.3.0rc0","introduced":"2.2.0"},{"fixed":"2.3.4","introduced":"2.3.0"},{"fixed":"2.4.3","introduced":"2.4.0"}],"component":"tensorflow-cpu","cve_ids":["CVE-2021-29552"],"ecosystem":"PyPI","epss":0.00189,"exploited":false,"fixed_versions":["2.2.0rc0","2.3.0rc0","2.3.4","2.4.3"],"ghsa_id":"GHSA-jhq9-wm9m-cf89","id":"tcs_01M5KGDARK44WK4A4N5TMTB0XK","modified_at":"2023-12-06T01:01:05.626837Z","published_at":"2021-05-14T20:15:00Z","references":["https://osv.dev/vulnerability/PYSEC-2021-480","https://github.com/tensorflow/tensorflow/security/advisories/GHSA-jhq9-wm9m-cf89","https://github.com/tensorflow/tensorflow/commit/704866eabe03a9aeda044ec91a8d0c83fc1ebdbe"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"PYSEC-2021-480","url":"https://osv.dev/vulnerability/PYSEC-2021-480"}],"summary":"TensorFlow is an end-to-end open source platform for machine learning. An attacker can cause a denial of service by controlling the values of `num_segments` tensor argument for `UnsortedSegmentJoin`."}