{"action":"Upgrade pysaml2 to 6.5.0 or later.","affected":[{"fixed":"6.5.0","introduced":"0"}],"component":"pysaml2","cve_ids":["CVE-2021-21239"],"ecosystem":"PyPI","epss":0.01291,"exploited":false,"fixed_versions":["6.5.0"],"ghsa_id":"GHSA-5p3x-r448-pc62","id":"tcs_01M5KGDCWBH4PZCKR5XMR1GR54","modified_at":"2023-11-08T04:04:39.128716Z","published_at":"2021-01-21T15:15:00Z","references":["https://osv.dev/vulnerability/PYSEC-2021-49","https://www.aleksey.com/pipermail/xmlsec/2013/009717.html","https://pypi.org/project/pysaml2","https://github.com/IdentityPython/pysaml2/releases/tag/v6.5.0","https://github.com/IdentityPython/pysaml2/security/advisories/GHSA-5p3x-r448-pc62","https://github.com/IdentityPython/pysaml2/commit/46578df0695269a16f1c94171f1429873f90ed99","https://lists.debian.org/debian-lts-announce/2021/02/msg00038.html"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"PYSEC-2021-49","url":"https://osv.dev/vulnerability/PYSEC-2021-49"}],"summary":"PySAML2 is a pure python implementation of SAML Version 2 Standard. PySAML2 before 6.5.0 has an improper verification of cryptographic signature vulnerability. Users of pysaml2 that use the default Cr"}