{"action":"Upgrade tensorflow-cpu to 2.2.0rc0 or later.","affected":[{"fixed":"2.2.0rc0","introduced":"0"},{"fixed":"2.3.0rc0","introduced":"2.2.0"},{"fixed":"2.3.4","introduced":"2.3.0"},{"fixed":"2.4.3","introduced":"2.4.0"}],"component":"tensorflow-cpu","cve_ids":["CVE-2021-29571"],"ecosystem":"PyPI","epss":0.0024,"exploited":false,"fixed_versions":["2.2.0rc0","2.3.0rc0","2.3.4","2.4.3"],"ghsa_id":"GHSA-whr9-vfh2-7hm6","id":"tcs_01M5KGDEYN9E3E2XKDB95TAC94","modified_at":"2023-12-06T01:01:06.778678Z","published_at":"2021-05-14T20:15:00Z","references":["https://osv.dev/vulnerability/PYSEC-2021-499","https://github.com/tensorflow/tensorflow/commit/79865b542f9ffdc9caeb255631f7c56f1d4b6517","https://github.com/tensorflow/tensorflow/security/advisories/GHSA-whr9-vfh2-7hm6"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"PYSEC-2021-499","url":"https://osv.dev/vulnerability/PYSEC-2021-499"}],"summary":"TensorFlow is an end-to-end open source platform for machine learning. The implementation of `tf.raw_ops.MaxPoolGradWithArgmax` can cause reads outside of bounds of heap allocated data if attacker sup"}