{"action":"Upgrade tensorflow-cpu to 2.1.4 or later.","affected":[{"fixed":"2.1.4","introduced":"0"},{"fixed":"2.2.3","introduced":"2.2.0"},{"fixed":"2.3.3","introduced":"2.3.0"},{"fixed":"2.4.2","introduced":"2.4.0"}],"component":"tensorflow-cpu","cve_ids":["CVE-2021-29581"],"ecosystem":"PyPI","epss":0.00189,"exploited":false,"fixed_versions":["2.1.4","2.2.3","2.3.3","2.4.2"],"ghsa_id":"GHSA-vq2r-5xvm-3hc3","id":"tcs_01M5KGDGY2XSQG4K8BJ6VZ027F","modified_at":"2023-12-06T01:01:07.383116Z","published_at":"2021-05-14T20:15:00Z","references":["https://osv.dev/vulnerability/PYSEC-2021-509","https://github.com/tensorflow/tensorflow/security/advisories/GHSA-vq2r-5xvm-3hc3","https://github.com/tensorflow/tensorflow/commit/b1b323042264740c398140da32e93fb9c2c9f33e"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"PYSEC-2021-509","url":"https://osv.dev/vulnerability/PYSEC-2021-509"}],"summary":"TensorFlow is an end-to-end open source platform for machine learning. Due to lack of validation in `tf.raw_ops.CTCBeamSearchDecoder`, an attacker can trigger denial of service via segmentation faults"}