{"action":"Upgrade tensorflow-cpu to 2.1.4 or later.","affected":[{"fixed":"2.1.4","introduced":"0"},{"fixed":"2.2.3","introduced":"2.2.0"},{"fixed":"2.3.3","introduced":"2.3.0"},{"fixed":"2.4.2","introduced":"2.4.0"}],"component":"tensorflow-cpu","cve_ids":["CVE-2021-29582"],"ecosystem":"PyPI","epss":0.00198,"exploited":false,"fixed_versions":["2.1.4","2.2.3","2.3.3","2.4.2"],"ghsa_id":"GHSA-c45w-2wxr-pp53","id":"tcs_01M5KGDHGZRACC4RXJTJ36YG9M","modified_at":"2023-12-06T01:01:07.444346Z","published_at":"2021-05-14T20:15:00Z","references":["https://osv.dev/vulnerability/PYSEC-2021-510","https://github.com/tensorflow/tensorflow/commit/5899741d0421391ca878da47907b1452f06aaf1b","https://github.com/tensorflow/tensorflow/security/advisories/GHSA-c45w-2wxr-pp53"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"PYSEC-2021-510","url":"https://osv.dev/vulnerability/PYSEC-2021-510"}],"summary":"TensorFlow is an end-to-end open source platform for machine learning. Due to lack of validation in `tf.raw_ops.Dequantize`, an attacker can trigger a read from outside of bounds of heap allocated dat"}