{"action":"Upgrade tensorflow-cpu to 2.2.0rc0 or later.","affected":[{"fixed":"2.2.0rc0","introduced":"0"},{"fixed":"2.3.0rc0","introduced":"2.2.0"},{"fixed":"2.3.4","introduced":"2.3.0"},{"fixed":"2.4.3","introduced":"2.4.0"}],"component":"tensorflow-cpu","cve_ids":["CVE-2021-29583"],"ecosystem":"PyPI","epss":0.00211,"exploited":false,"fixed_versions":["2.2.0rc0","2.3.0rc0","2.3.4","2.4.3"],"ghsa_id":"GHSA-9xh4-23q4-v6wr","id":"tcs_01M5KGDHPEPT7HHKMRKJ2GQ3ER","modified_at":"2023-12-06T01:01:07.505271Z","published_at":"2021-05-14T20:15:00Z","references":["https://osv.dev/vulnerability/PYSEC-2021-511","https://github.com/tensorflow/tensorflow/commit/6972f9dfe325636b3db4e0bc517ee22a159365c0","https://github.com/tensorflow/tensorflow/security/advisories/GHSA-9xh4-23q4-v6wr"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"PYSEC-2021-511","url":"https://osv.dev/vulnerability/PYSEC-2021-511"}],"summary":"TensorFlow is an end-to-end open source platform for machine learning. The implementation of `tf.raw_ops.FusedBatchNorm` is vulnerable to a heap buffer overflow. If the tensors are empty, the same imp"}