{"action":"Upgrade fastify to 5.12.1 or later.","affected":[{"fixed":"5.12.1","introduced":"0"}],"component":"fastify","cve_ids":["CVE-2026-18504"],"ecosystem":"npm","epss":0.0028,"exploited":false,"fixed_versions":["5.12.1"],"ghsa_id":"GHSA-w2qp-rph6-63g4","id":"tcs_01M5KGDJQE3SD8MHA7SN34WV7F","modified_at":"2026-09-02T15:31:16.770992110Z","published_at":"2026-09-02T15:13:23Z","references":["https://osv.dev/vulnerability/GHSA-w2qp-rph6-63g4","https://github.com/fastify/fastify/security/advisories/GHSA-w2qp-rph6-63g4","https://nvd.nist.gov/vuln/detail/CVE-2026-18504","https://github.com/fastify/fastify/commit/1ef8a60c87e94f42f666aa15ad68957772a83655","https://cna.openjsf.org/security-advisories.html","https://github.com/fastify/fastify","https://github.com/fastify/fastify/releases/tag/v5.12.1"],"severity":{"label":"medium","score":5.4},"sources":[{"source":"osv","source_id":"GHSA-w2qp-rph6-63g4","url":"https://osv.dev/vulnerability/GHSA-w2qp-rph6-63g4"}],"summary":"fastify vulnerable to schema validation bypass via root primitive coercion mismatch"}