{"action":"Upgrade tensorflow-gpu to 2.2.0rc0 or later.","affected":[{"fixed":"2.2.0rc0","introduced":"0"},{"fixed":"2.3.0rc0","introduced":"2.2.0"},{"fixed":"2.3.4","introduced":"2.3.0"},{"fixed":"2.4.3","introduced":"2.4.0"}],"component":"tensorflow-gpu","cve_ids":["CVE-2021-29566"],"ecosystem":"PyPI","epss":0.00201,"exploited":false,"fixed_versions":["2.2.0rc0","2.3.0rc0","2.3.4","2.4.3"],"ghsa_id":"GHSA-pvrc-hg3f-58r6","id":"tcs_01M5KGENJEAF7K4VNS0V8EDMA6","modified_at":"2023-12-06T01:01:06.473717Z","published_at":"2021-05-14T20:15:00Z","references":["https://osv.dev/vulnerability/PYSEC-2021-692","https://github.com/tensorflow/tensorflow/commit/3f6fe4dfef6f57e768260b48166c27d148f3015f","https://github.com/tensorflow/tensorflow/security/advisories/GHSA-pvrc-hg3f-58r6"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"PYSEC-2021-692","url":"https://osv.dev/vulnerability/PYSEC-2021-692"}],"summary":"TensorFlow is an end-to-end open source platform for machine learning. An attacker can write outside the bounds of heap allocated arrays by passing invalid arguments to `tf.raw_ops.Dilation2DBackpropI"}