{"action":"Upgrade tensorflow-gpu to 2.1.4 or later.","affected":[{"fixed":"2.1.4","introduced":"0"},{"fixed":"2.2.3","introduced":"2.2.0"},{"fixed":"2.3.3","introduced":"2.3.0"},{"fixed":"2.4.2","introduced":"2.4.0"}],"component":"tensorflow-gpu","cve_ids":["CVE-2021-29570"],"ecosystem":"PyPI","epss":0.00154,"exploited":false,"fixed_versions":["2.1.4","2.2.3","2.3.3","2.4.2"],"ghsa_id":"GHSA-545v-42p7-98fq","id":"tcs_01M5KGEP6FHZ0EZ1NB66ATZ2YA","modified_at":"2023-12-06T01:01:06.718430Z","published_at":"2021-05-14T20:15:00Z","references":["https://osv.dev/vulnerability/PYSEC-2021-696","https://github.com/tensorflow/tensorflow/commit/dcd7867de0fea4b72a2b34bd41eb74548dc23886","https://github.com/tensorflow/tensorflow/security/advisories/GHSA-545v-42p7-98fq"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"PYSEC-2021-696","url":"https://osv.dev/vulnerability/PYSEC-2021-696"}],"summary":"TensorFlow is an end-to-end open source platform for machine learning. The implementation of `tf.raw_ops.MaxPoolGradWithArgmax` can cause reads outside of bounds of heap allocated data if attacker sup"}