{"action":"Upgrade tensorflow-gpu to 2.1.4 or later.","affected":[{"fixed":"2.1.4","introduced":"0"},{"fixed":"2.2.3","introduced":"2.2.0"},{"fixed":"2.3.3","introduced":"2.3.0"},{"fixed":"2.4.2","introduced":"2.4.0"}],"component":"tensorflow-gpu","cve_ids":["CVE-2021-29576"],"ecosystem":"PyPI","epss":0.00211,"exploited":false,"fixed_versions":["2.1.4","2.2.3","2.3.3","2.4.2"],"ghsa_id":"GHSA-7cqx-92hp-x6wh","id":"tcs_01M5KGEQFZXCTRSWXM43KNBFYK","modified_at":"2023-12-06T01:01:07.083753Z","published_at":"2021-05-14T20:15:00Z","references":["https://osv.dev/vulnerability/PYSEC-2021-702","https://github.com/tensorflow/tensorflow/security/advisories/GHSA-7cqx-92hp-x6wh","https://github.com/tensorflow/tensorflow/commit/63c6a29d0f2d692b247f7bf81f8732d6442fad09"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"PYSEC-2021-702","url":"https://osv.dev/vulnerability/PYSEC-2021-702"}],"summary":"TensorFlow is an end-to-end open source platform for machine learning. The implementation of `tf.raw_ops.MaxPool3DGradGrad` is vulnerable to a heap buffer overflow. The implementation(https://github.c"}