{"action":"Upgrade @hono/node-server to 1.19.10 or later.","affected":[{"fixed":"1.19.10","introduced":"0"}],"component":"@hono/node-server","cve_ids":["CVE-2026-29087"],"ecosystem":"npm","epss":0.00363,"exploited":false,"fixed_versions":["1.19.10"],"ghsa_id":"GHSA-wc8c-qw6v-h7f6","id":"tcs_01M5KGEQPHQNS4EH480HXQWH3V","modified_at":"2026-09-10T03:50:41.582966467Z","published_at":"2026-03-04T20:05:49Z","references":["https://osv.dev/vulnerability/GHSA-wc8c-qw6v-h7f6","https://github.com/honojs/node-server/security/advisories/GHSA-wc8c-qw6v-h7f6","https://nvd.nist.gov/vuln/detail/CVE-2026-29087","https://github.com/honojs/node-server/commit/455015be1697dd89974a68b70350ea7b2d126d2e","https://github.com/honojs/node-server"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"GHSA-wc8c-qw6v-h7f6","url":"https://osv.dev/vulnerability/GHSA-wc8c-qw6v-h7f6"}],"summary":"@hono/node-server has authorization bypass for protected static paths via encoded slashes in Serve Static Middleware"}