{"action":"Upgrade tensorflow-gpu to 2.1.4 or later.","affected":[{"fixed":"2.1.4","introduced":"0"},{"fixed":"2.2.3","introduced":"2.2.0"},{"fixed":"2.3.3","introduced":"2.3.0"},{"fixed":"2.4.2","introduced":"2.4.0"}],"component":"tensorflow-gpu","cve_ids":["CVE-2021-29584"],"ecosystem":"PyPI","epss":0.00189,"exploited":false,"fixed_versions":["2.1.4","2.2.3","2.3.3","2.4.2"],"ghsa_id":"GHSA-xvjm-fvxx-q3hv","id":"tcs_01M5KGES3H2P8E23S88PBS4HP8","modified_at":"2023-12-06T01:01:07.566057Z","published_at":"2021-05-14T20:15:00Z","references":["https://osv.dev/vulnerability/PYSEC-2021-710","https://github.com/tensorflow/tensorflow/security/advisories/GHSA-xvjm-fvxx-q3hv","https://github.com/tensorflow/tensorflow/commit/4c0ee937c0f61c4fc5f5d32d9bb4c67428012a60"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"PYSEC-2021-710","url":"https://osv.dev/vulnerability/PYSEC-2021-710"}],"summary":"TensorFlow is an end-to-end open source platform for machine learning. An attacker can trigger a denial of service via a `CHECK`-fail in caused by an integer overflow in constructing a new tensor shap"}