{"action":"Upgrade vm2 to 3.6.11 or later.","affected":[{"fixed":"3.6.11","introduced":"0"}],"component":"vm2","cve_ids":["CVE-2019-10761"],"ecosystem":"npm","epss":0.01329,"exploited":false,"fixed_versions":["3.6.11"],"ghsa_id":"GHSA-wf5x-cr3r-xr77","id":"tcs_01M5KGEV7FCGXMQVCA6SZ8MA1C","modified_at":"2026-09-10T03:49:44.870714495Z","published_at":"2022-07-14T00:00:23Z","references":["https://osv.dev/vulnerability/GHSA-wf5x-cr3r-xr77","https://nvd.nist.gov/vuln/detail/CVE-2019-10761","https://github.com/patriksimek/vm2/issues/197","https://github.com/patriksimek/vm2/issues/197#issuecomment-480643832","https://github.com/patriksimek/vm2/commit/4b22d704e4794af63a5a2d633385fd20948f6f90","https://gist.github.com/JLLeitschuh/609bb2efaff22ed84fe182cf574c023a","https://github.com/patriksimek/vm2","https://snyk.io/vuln/SNYK-JS-VM2-473188"],"severity":{"label":"high","score":8.3},"sources":[{"source":"osv","source_id":"GHSA-wf5x-cr3r-xr77","url":"https://osv.dev/vulnerability/GHSA-wf5x-cr3r-xr77"}],"summary":"vm2 before 3.6.11 vulnerable to sandbox escape"}